Вывести таблицу значений функции в Pascal

Вывести таблицу значений функции в Pascal

Используя цикл написать программу, которая выводит на экран таблицу значений функции y = 5 - x2/2 на отрезке [-5; 5] с шагом 0.5.

Алгоритм решения задачи:

  1. Присвоить переменной x значение начала отрезка.
  2. Пока x не достигнет конца отрезка
    1. вычислять значение y по формуле,
    2. вывести на экран значение x и y,
    3. увеличить x на заданный шаг.

Программа на языке Паскаль:

var
    x, y: real;

begin
    x := -5;

    writeln(' x      y  ');

    while x <= 5 do begin
        y := 5 - x*x/2;
        writeln(x:4:1,' | ',y:5:2);
        x := x + 0.5
    end;
end.

Результат выполнения программы:

 x      y
-5.0 | -7.50
-4.5 | -5.13
-4.0 | -3.00
-3.5 | -1.13
-3.0 |  0.50
-2.5 |  1.88
-2.0 |  3.00
-1.5 |  3.88
-1.0 |  4.50
-0.5 |  4.88
 0.0 |  5.00
 0.5 |  4.88
 1.0 |  4.50
 1.5 |  3.88
 2.0 |  3.00
 2.5 |  1.88
 3.0 |  0.50
 3.5 | -1.13
 4.0 | -3.00
 4.5 | -5.13
 5.0 | -7.50