Посчитать четные и нечетные цифры числа в Pascal

Посчитать четные и нечетные цифры числа в Pascal

Написать программу, подсчитывающую количество четных и нечетных цифр числа.

Описание переменных:

Алгоритм решения задачи:

  1. Если число делится без остатка на 2, значит его последняя цифра четная (увеличиваем переменную even). Иначе последняя цифра нечетная, тогда увеличиваем на 1 значение uneven).
  2. Избавляемся от младшего разряда числа, разделив его нацело (div) на 10.

Программа на языке Паскаль:

var
    a: longint;
    even, uneven: byte;

begin
    readln(a);

    even := 0;
    uneven := 0;

    while a > 0 do begin
        if (a mod 2) = 0 then
            even := even + 1
        else
            uneven := uneven + 1;
        a := a div 10;
    end;

    writeln('Even: ', even);
    writeln('Uneven: ', uneven);
end.

Пример выполнения программы:

84521
Even: 3
Uneven: 2