Вычисление значения функции в Pascal

Вычисление значения функции в Pascal

Требуется написать программу, вычисляющую значение какой-либо функции у = f(x). Например, такой:

у = x – 2, если x > 0,
y = 0, если x = 0,
y = |x|, если x < 0.

Примеры выполнения программы

x = 6
y = 4
x = 0
y = 0
x = -2
y = 2
var
    x, y: integer;

begin
    write('x = ');
    readln(x);

    if x > 0 then
        y := x - 2
    else
        if x = 0 then
            y := 0
        else
            y := abs(x);

    writeln('y = ', y);
end.

При определении значений подобных функций переменная y вычисляется по-разному (по разным формулам) в зависимости от значения x.

Такие задачи решаются с помощью конструкции условного оператора if-else. Поскольку в данном случае мы имеем три условия (x > 0, x = 0 и x < 0), то потребуется использование еще вложенной конструкции if-else, так как в языке Pascal нет оператора множественного ветвления (оператор-"переключатель" case в данном случае не подходит).

В языке программирования Паскаль (да и в других тоже) желательно вложенные конструкции if-else помещать во внешнюю ветку else, а не if. Так проще не запутаться.

Таким образом, алгоритм вычисления значения функции может быть таким:

  1. Если x > 0, то у = x - 2
  2. Иначе (ниже идет вложенная конструкция)
  3. Если x = 0, то y = 0
  4. Иначе y = |x|.

В последнем пункте можно опустить оператор if с проверкой, что x < 0, так как если ход выполнения программы дошел до этого пункта, то x уже другим быть и не может (варианты, когда он больше или равен нулю, уже были исключены).

Для определения модуля (абсолютного значения) переменной можно использовать встроенную функцию abs() языка Pascal. В данном случае можно обойтись и без нее: поскольку уже известно, что x отрицателен, то, чтобы получить положительное число (модуль), нужно его умножить на -1.