Возведение числа в степень в Pascal

Возведение числа в степень в Pascal

Написать программу на языке Pascal, которая возводит число в целочисленную степень. Число и степень вводятся с клавиатуры.

Чтобы возвести число в степень, его надо умножить само на себя количество раз, равное показателю степени. То есть возведение числа n в степень d будет выглядеть так:

nd = n1 * n2 * n3 * … * nd,

где индексы внизу просто указывают очередное по счету n.

Если d (степень) равна нулю, то какое бы число не стояло в основании степени, результат всегда будет равен единице:

n0 = 1.

Если показатель степени отрицателен (d < 0), то результат определяется формулой:

nd = 1 / (n1 * n2 * n3 * … * nd).

В примере программы на языке Паскаль количество итераций (повторений) цикла равно модулю показателя степени числа (переменная deg).

Если значение deg равно нулю, то цикл не выполнится ни разу. В результате переменная res будет содержать значение 1.

Если задан отрицательный показатель степени, то нужно разделить единицу на значение переменной res.

Программа на языке Паскаль:

var
    deg: integer;
    num, res: real;
    i: byte;

begin
    write('Число: '); readln(num);
    write('Степень: '); readln(deg);

    res := 1;

    for i := 1 to abs(deg) do
        res := res * num;

    if deg < 0 then
        res := 1 / res;

    writeln(res:10:3);

end.

Примеры выполнения программы:

Число: -3.2
Степень: 3
   -32.768
Число: 5
Степень: -2
     0.040

Вариант программы ниже позволяет возводить неотрицательное число в дробную степень:

var
    num, deg: real;
    res: real;

begin
    write('Число: '); readln(num);
    write('Степень: '); readln(deg);

    res := exp(num * LN(deg));

    writeln(res:10:3);
end.

Пример выполнения:

Число: 3.2
Степень: 2.9
    30.177