Проверочная работа к курсу "Основы языка C"
1. Если массив arr содержит строку, то будут ли различаться значения, которые вернут функции sizeof()
и strlen()
?
2. Напишите код, в котором одной переменной присваивается введенное пользователем число, а второй переменной – модуль этого числа. После этого значение второй переменной выводится на экран. Используйте условное выражение, а не инструкцию if
.
3. Переделайте условное выражение из предыдущего задания в макрос.
4. Запрограммируйте вывод на экран символов так, как показано на рисунке. Используйте циклы for
, а также если необходимо функцию strcat()
.
5. Напишите программу, которая определяет в процентном соотношении количество гласных и согласных букв в текстовом файле. Имя файла передается в программу через командную строку.
6. Как изменить приведенную ниже программу так, чтобы среди параметров функции sum не было указателя, а функция возвращала значение, оставляя тем самым возможность изменить значение любой внешней переменной?
#include <stdio.h> void sum (float *base, float add); main() { float a=100, b; scanf("%f", &b); sum(&a, b); printf("%.4f\n", a); } void sum (float *base, float add) { *base = *base + add/2; }
7. Напишите программу, в которой массив заполняется случайными буквами английского алфавита; значения элементов массива в символьном представлении выводятся на экран.
8. Напишите функцию, которая принимает указатели на два массива. Функция должна заполнять один массив 25-ю случайными четными числами, а другой — 25 нечетными. Продемонстрируйте ее работу.
9. Пользователь вводит две строки, каждая строка состоит из двух слов, разделенных пробелом. Требуется сравнить строки лексикографически, начиная со второго слова (т.е. после пробела). Напишите программу, выполняющую описанную задачу.
Курс с решением задач:
pdf-версия