Массивы и указатели в языке C

Адресная арифметика

Рассмотрим программу:

#include <stdio.h>
 
#define N 5
 
int main() {
    int arr[N], i;
 
    for (i = 0; i < N; i++)
        printf("%p\n", &arr[i]);
}

Создается массив arr, далее в цикле for выводятся значения адресов ячеек памяти каждого элемента массива. Результат выполнения программы будет выглядеть примерно так:

0x7ffe7d9ffe10
0x7ffe7d9ffe14
0x7ffe7d9ffe18
0x7ffe7d9ffe1c
0x7ffe7d9ffe20

Обратите внимание на то, что значение адреса каждого последующего элемента массива больше значения адреса предыдущего элемента на 4 единицы. В вашей системе эта разница может составлять 2 единицы. Такой результат вполне объясним, если вспомнить, сколько байтов отводится на одно данное типа int, и что элементы массива сохраняются в памяти друг за другом.

Теперь объявим указатель на целый тип и присвоим ему адрес первого элемента массива:

int *p;
 
p = &arr[0];

Цикл for изменим таким образом:

for (i = 0; i < N; i++)
    printf("%p\n", p + i);

Здесь к значению p, которое является адресом ячейки памяти, прибавляется сначала 0, затем 1, 2, 3 и 4. Можно было бы предположить, что прибавление к p единицы в результате дает адрес следующего байта за тем, на который указывает p. А прибавление двойки вернет адрес байта, через один от исходного. Однако подобное предположение не верно.

Вспомним, что тип указателя сообщает, на сколько байт простирается значение по адресу, на который он указывает. Таким образом, хотя p указывает только на один байт (первый), но "знает", что его "собственность" простирается на все четыре. Когда мы прибавляем к указателю единицу, то получаем указатель на следующее значение, но никак не на следующий байт. А следующее значение начинается только через 4 байта. Поэтому результат выполнения приведенного цикла с указателем правильно отобразит адреса элементов массива.

Прибавляя к указателям (или вычитая из них) целые значения, мы имеем дело с так называемой адресной арифметикой.

Напишите программу, в которой объявлен массив вещественных чисел из десяти элементов. Присвойте указателю адрес четвертого элемента, затем, используя цикл, выведите на экран адреса 4, 5 и 6-ого элементов массива.

Имя массива - это указатель на адрес его первого элемента

Да, это именно так, данный факт следует принять как аксиому. Вы можете убедиться в этом выполнив такое выражение:

printf("%p = %p\n", arr, &arr[0]);

Отсюда следует, что имя массива – это ничто иное, как указатель. (Хотя это немного особенный указатель, о чем будет упомянуто ниже.) Поэтому выражения p = &arr[0] и p = arr дают одинаковый результат: присваивают указателю p адрес первого элемента массива.

Раз имя массива — это указатель, ничего не мешает получать адреса элементов вот так:

for (int i = 0; i < N; i++)
    printf("%p\n", arr + i);

Соответственно значения элементов массива можно получить так:

for (int i = 0; i < N; i++)
    printf("%.1f ", *(arr + i));

Примечание. Если массив был объявлен как автоматическая переменная (т.е. не глобальная и не статическая) и при этом не был инициализирован (не присваивались значения), то в нем будет содержаться "мусор" (случайные числа).

Получается, что запись вида arr[3] является сокращенным (более удобным) вариантом выражения *(arr+3).

Взаимозаменяемость имени массива и указателя

Если имя массива является указателем, то почему бы не использовать обычный указатель в нотации обращения к элементам массива также, как при обращении через имя массива:

#include <stdio.h>
#define N 5
 
int main() {
    int arr[N] = {4, 0, 3, 10, 9};
    int *p;
 
    p = arr;
 
    for (int i = 0; i < N; i++)
        printf("%d\n", p[i]);
}

Отсюда следуют выводы. Если arr — массив, а p — указатель на его первый элемент, то пары следующих выражений дают один и тот же результат:

Указателю можно присвоить адрес любого из элементов массива. Например, так p = &arr[2] или так p = arr + 2. В таком случае результат приведенных выше пар выражений совпадать не будет. Например, когда будет выполняться выражение arr[i], то будет возвращаться i-ный элемент массива. А вот выражение p[i] уже вернет не i-ный элемент от начала массива, а i-ный элемент от того, адрес которого был присвоен p. Например, если p был присвоен адрес третьего элемента массива (p = arr + 2), то выражение arr[1] вернет значение второго элемента массива, а p[1] ‒ четвертого.

Имя массива — это указатель-константа

Несмотря на вышеописанную взаимозаменяемость имени массива определенного типа на указатель того же типа, между ними есть разница. Указатель может указывать на любой элемент массива, его значение можно изменять. Имя массива всегда указывает только на первый элемент массива, изменять его значение нельзя.

Это значит, что выражение p = arr допустимо, а arr = p — нет. Имя массива является константой. При этом не надо путать имя массива (адрес) и значения элементов массива. Последние константами не являются. Действительно, ведь для всех переменных мы не можем менять их адрес в процессе выполнения программы, можем менять лишь их значения. В этом смысле имя массива — это обычная переменная, хотя и содержащая адрес.

Как следствие в программном коде выражения присваивания, инкрементирования и декрементирования допустимы для указателей, а для имени массива — запрещены.

Рассмотрим программу:

#include <stdio.h>
 
int main() {
    char str[20], *ps = str, n = 0;
 
    printf("Enter word: ");
    scanf("%s", str);
 
    while(*ps++ != '\0') n++;
 
    printf("%d\n", n);
}

Она подсчитывает количество букв в полученном слове. Указатель ps получает ссылку на первый элемент массива, то есть первую букву. В условии цикла while сначала извлекается символ по адресу указателя и только потом значение указателя инкрементируется. Извлеченный символ проверяется на неравенство символу конца строки. И только в этом случае счетчик букв увеличивается.

Курс с решением задач:
pdf-версия


Основы языка C. Курс




Все разделы сайта